pfSense <= 2.3.1_1 - Command Execution - Alerta aos Administradores de Redes.

Atenção aos administradores de Redes que utilizam o pfSense como firewall, embora hoje estejamos já na versão 2.4.1 que não é afetada por esta falha, sabemos que muitos utilizam versões anteriores e não mantem seus sistemas atualizados, falha grave no que se refere a segurança.
Nós da Linux Force Security sempre consideramos que o menos é mais quando se trata de segurança. Uma prova disto são falhas relacionadas a softwares que deveriam aumentar a segurança, mas que uma vez ou outra infelizmente abrem brechas justamente opostas ao que se remetem.
Vale lembrar que em março deste ano tivemos uma outra falha relacionada a mesma ferramenta, que naquela época se referia a ataques do tipo Cross-Site Scripting / Cross-Site Request Forgery que afetava uma versão superior a esta, mais especificamente a versão 2.3.2, informações detalhadas sobre esta falha podem ser encontradas clicando aqui .

Sem mais delongas:

Exploit Title: pfSense <= 2.3.1_1 Post-Auth Command Execution
Date: 11-06-2017
Exploit Author: s4squatch (Scott White – www.trustedsec.com)
Vendor Homepage: https://www.pfsense.org
Version: 2.3-RELEASE
Vendor Security Advisory: https://www.pfsense.org/security/advisories/pfSense-SA-16_08.webgui.asc

1. Descrição
As versões do pfSense <= 2.3.1_1 são afetadas por uma vulnerabilidade de injeção de comando pós-autenticação no servidor instalado em auth.inc através da página /system_groupmanager.php (menu Sistema -> Gerenciador de usuários -> Grupos) no gerenciamento do parâmetro [] dos membros . Isso permite que um usuário autenticado da WebGUI com privilégios no system_groupmanager.php executar comandos no contexto do usuário root do servidor em questão.

2. Prova do conceito
‘`ifconfig>/usr/local/www/ifconfig.txt`’
‘`whoami>/usr/local/www/whoami.txt`’

A saída do comando pode ser visualizada da seguinte forma:
http://<endereço>/ifconfig.txt
http://<endereço>/whoami.txt

Outra prova do conceito:  0′;/sbin/ping -c 10 192.168.1.125;’  (lembre-se de substituir este ip)
3. Solução
Atualize para a versão mais recente do pfSense (2.3.1_5 acima esta corrigido). Isso pode ser realizado na interface web ou do
console. Consulte https://doc.pfsense.org/index.php/Upgrade_Guide Além disso, os problemas podem ser atenuados restringindo o acesso à interface gráfica do firewall tanto com regras de firewall quanto não permitindo que usuários não confiáveis ​​tenham contas com acesso a mesma interface e não concedendo acesso de administradores não confiáveis ​​às páginas em questão.O problema foi divulgado de forma responsável no pfSense (security@pfsense.org) em 06/08/2016 e corrigido em 06/09/2016!
Parabéns a equipe do PfSense pelo impressionante tempo de resposta.
 
Fonte https://www.exploit-db.com/exploits/43128/
8 de novembro de 2017

Sobre nós

A Linux Force Brasil é uma empresa que ama a arte de ensinar. Nossa missão é criar talentos para a área de tecnologia e atender com excelência nossos clientes.

CNPJ: 13.299.207/0001-50
SAC:         0800 721 7901

sac@linuxforce.com.br

Comercial: 11 3796-7900

Suporte:    11 3976-5900
contato@linuxforce.com.br

Últimos Tweets

Administrador Online

Não há usuários online neste momento
Copyright © Linux Force Security  - Desde 2011.